protect your practice from eScriptMessenger’s security vulnerability

We’re reaching out to your athenaPractice and athenaFlow customers on July 10, 2020 to inform them of the security vulnerability with Surescipts’ eScriptMessenger. All versions are susceptible. This security vulnerability impacts all sites using athenaPractice or athenaFlow for electronic prescribing. We provide steps to take to protect against the issue.

Read More about this -> HERE