URGENT - ACTION REQUIRED: Update Surescripts servers to TLS v1.2 by 2/24/2019 or lose functionality

URGENT – ACTION REQUIRED: Update Surescripts Servers to TLS v1.2 by 2/24/2019 or Lose Functionality

Dear Centricity™ Customers:

As your essential partner for better healthcare outcomes, we are committed to keeping you informed of important changes that affect our technology.

The purpose of this communication is to inform you that Surescripts requires that all practices using any of the following applications must increase the server security protocols to TLS (Transport Layer Security) v1.2 by February 24, 2019:

  • eScriptMessenger (ePrescribing)
  • Document Management
  • Patient Portal
  • Secure Messaging
  • Automated Clinical Messaging

Failure to make these changes will result in a loss of functionality with the listed applications. Read the communication and FAQ from Virence Health in the links below for more information.

TLS v1.2 Notice

TLS v1.2 FAQ